Power Hungry Performance Forum  

Go Back   Power Hungry Performance Forum > Ford Super Duty & Excursion > 1999 to 2003 7.3L Power Stroke Diesel

1999 to 2003 7.3L Power Stroke Diesel 7.3L Power Stroke Diesel equipped Super Duty and Excursion

Reply
 
Thread Tools Display Modes
  #1  
Old Mon, November 21st, 2022, 10:28 PM
jasonstiffey jasonstiffey is offline
Whopper Junior
 
Join Date: Aug 2022
Posts: 2
jasonstiffey is on a distinguished road
Default Is this normal?

2003 F350 with auto transmission.
Engine completely rebuilt mechanically less than 1000 miles ago.

So recently installed single shot injectors and a Hydra chip to run them.
Had a minor oops when starting and accidently started the truck on the old Gryphon towing tune with the hydra tune on top.
It was interesting but ran. Shut it down and restored the PCM to stock then started over.

Truck was running good for a minute then started to shut down and give me all kinds of fits.

Ran codes and replaced the Cam position sensor and ICP sensor.

Now the truck is running awesome, but I keep getting a couple codes after a warm start.

First start of the day the truck will lope a bit but a little throttle or going to high idle smooths it out.
When I restart after getting it warmed up for a bit I get these two codes but they clear in less than 5 minutes.

Found them in the Continuous memory only not the DTC's.

P1280
Injection Control Pressure Sensor Circuit Low

PP1249
Wastegate Control Valve Performance (totally new one today)

Again truck runs just fine and the ICP was just replace HOWEVER I did not replace the pigtail.
Prior to the ICP the truck was surging and shutting down so I know it was bad. We found the o-ring torn and leaking so I'm sure that was the culprit.

So any ideas?

Maybe not related or maybe it is....
Taillights and dash lights have decided to stop working.
Headlight switch has been replaced already..

I'm wondering if the PCM has some damage to it from the accidental "double tune" when I first installed the Hydra.

Also anyone have the dang diagram for the 6 relays under the hood?
They are not marked, listed in my manual or anything.
I'm pretty sure the two little ones are for the tail lights, but didn't want to go randomly replacing them just yet.
I attached a picture of them firewall is to the bottom of the photo.
Attached Images
File Type: jpg relays f350.jpg (742.4 KB, 3 views)
Reply With Quote
  #2  
Old Thu, November 24th, 2022, 06:25 AM
Power Hungry's Avatar
Power Hungry Power Hungry is offline
The Godfather of Power Stroke Tuning
 
Join Date: Nov 2008
Location: Winder, GA
Posts: 2,452
Power Hungry has much to be proud ofPower Hungry has much to be proud ofPower Hungry has much to be proud ofPower Hungry has much to be proud ofPower Hungry has much to be proud ofPower Hungry has much to be proud ofPower Hungry has much to be proud ofPower Hungry has much to be proud of
Default

After you clear the codes, are they returning every day?

What is your PCM Box Code and what Calibration HEX Code are you running on the chip?
__________________
Bill Cohron - The Mad Doctor

Power Hungry Performance - The ORIGINAL in Ford performance tuning... Since 1996!
(678) 890-1110

www.gopowerhungry.com - Home of the Hydra Chip, Minotaur Tuning Software, and the new Orion Reflash System for Navistar!

Bring back Windows™ XP and 7.
Windows™ Vista and Windows™ 8 is a pain in my a$$!
Windows™ 10 is only slightly less annoying!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:49 AM.


All Contents Copyright 2008-2020, Power Hungry Performance