Power Hungry Performance Forum  

Go Back   Power Hungry Performance Forum > Ford F-150, Expedition, Navigator, Blackwood, Mark-LT, SVT Lightning and H-D Editions > 1997 to 2009 Expedition and Navigator

1997 to 2009 Expedition and Navigator 4.6L and 5.4L (2V and 3V) equipped Expeditions and Navigators

Reply
 
Thread Tools Display Modes
  #1  
Old Fri, February 24th, 2012, 10:53 AM
demontang demontang is offline
Whopper
 
Join Date: Jul 2011
Posts: 16
demontang is on a distinguished road
Default Loss of highway mpg

Ive noticed a loss in my highway mpg. I've gone from 16+ to 8-11mpg? I noticed some of it after I took 3" of lift off and went down 4" in tire size. I've got 3.73 gears 4"lift and 33" tires.
Reply With Quote
  #2  
Old Fri, February 24th, 2012, 12:18 PM
88Racing's Avatar
88Racing 88Racing is offline
SENIOR MODERATOR
 
Join Date: Feb 2009
Location: Somewhere ....
Posts: 5,818
88Racing is a glorious beacon of light88Racing is a glorious beacon of light88Racing is a glorious beacon of light88Racing is a glorious beacon of light88Racing is a glorious beacon of light88Racing is a glorious beacon of light
Default

Make sure when you used custom options and redid the new tire size that you also checked your gear ratio also....
__________________
SENIOR MODERATOR--PTLA

God doesn't have a Facebook but he's my friend.
God doesn't have a twitter, but I follow him.
Reply With Quote
  #3  
Old Fri, February 24th, 2012, 01:47 PM
demontang demontang is offline
Whopper
 
Join Date: Jul 2011
Posts: 16
demontang is on a distinguished road
Default

I'll check that I just put new rims and tires on today because the old ones where to loud for me lol and the rims had almost no clearance on the calipers. It feels like it takes less pedal now but I don't think that's the problem.
Reply With Quote
  #4  
Old Fri, March 23rd, 2012, 10:18 AM
demontang demontang is offline
Whopper
 
Join Date: Jul 2011
Posts: 16
demontang is on a distinguished road
Default

Ok got my custom tunes and Im running the 87 performance tune right now. I'm getting 13-14mpg intown running 30-45 mph but when I hit the freeway Im getting 4-8 mpg a tank even going do a steep hill it only reads 8 mpg?? Ive pulled the codes and only get p1000 and Ill get that cleared by doing the run cycle and after it sits over night that code comes back. Ill get code p0420 and p0430 once a week now which is because I dont have cats or maybe the O2 is going I dont know. The highway mpg has me confused though
Reply With Quote
  #5  
Old Fri, March 23rd, 2012, 10:33 AM
cleatus12r's Avatar
cleatus12r cleatus12r is offline
F Your Yankee Blue Jeans
 
Join Date: Jan 2009
Location: Somewhere in Montana
Posts: 3,063
cleatus12r is a name known to allcleatus12r is a name known to allcleatus12r is a name known to allcleatus12r is a name known to allcleatus12r is a name known to allcleatus12r is a name known to all
Default

You need to do an ACTUAL test over a few tanks of fuel with actual mileage (make sure your odometer is correct) and gallons used. Watching the overhead display is by no means accurate.
Reply With Quote
  #6  
Old Fri, March 23rd, 2012, 12:26 PM
Longshot270's Avatar
Longshot270 Longshot270 is offline
Forum Predator
 
Join Date: Jul 2009
Location: DFW, TX
Posts: 2,688
Longshot270 will become famous soon enough
Default

Quote:
Originally Posted by cleatus12r View Post
You need to do an ACTUAL test over a few tanks of fuel with actual mileage (make sure your odometer is correct) and gallons used. Watching the overhead display is by no means accurate.
X2, your mileage reports need to be a calculation that you do at every fill up. Even though we are in the 21st century computers are still really stupid. They are only made to appear intelligent.
__________________
Reply With Quote
  #7  
Old Fri, March 23rd, 2012, 02:41 PM
demontang demontang is offline
Whopper
 
Join Date: Jul 2011
Posts: 16
demontang is on a distinguished road
Default

I checked it on a few ranks and the tune mog if off by 0-.2mpg on average. My last three intown tanks where 13.3, 14.1, and 13.9 with morning warm up for 5-10min. My last three highway where 7.7,5.7 and 6.5 it's terrible. I can hook up my 6000lb trailer and do better in town then my unloaded highway. I have had a dealer look it over and they found no codes etc either. They thought the mileage is reversed cause they don't hear of 14 in town. I'm about to cut my loss and move on to a different rig. I was getting better mpg with 37" tires and 3" of lift cause I averaged 16mpg highway over the mountain pass and down to oregon.
Reply With Quote
  #8  
Old Fri, March 23rd, 2012, 03:45 PM
Longshot270's Avatar
Longshot270 Longshot270 is offline
Forum Predator
 
Join Date: Jul 2009
Location: DFW, TX
Posts: 2,688
Longshot270 will become famous soon enough
Default

At the moment I'm gonna guess that you may have something dragging like the parking brake. In lower gears it won't hurt quite as much. But I'll keep thinking. There is something funny going on.
__________________
Reply With Quote
  #9  
Old Fri, March 23rd, 2012, 05:40 PM
demontang demontang is offline
Whopper
 
Join Date: Jul 2011
Posts: 16
demontang is on a distinguished road
Default

I'm wondering about my egr system
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:37 PM.


All Contents Copyright 2008-2020, Power Hungry Performance