Results 1 to 7 of 7

Thread: Rough idle when decelerating with new tunes on Hydra

  1. #1

    Help Rough idle when decelerating with new tunes on Hydra

    Hello all. For starters, this is on a 2000 Ford F250 7.3L, with 4" turbo back straight pipe, Stage 2 150hp injectors, and rebuilt engine (bored and sleeved, COMP 910 valve springs, ARP studs, the list goes on.) with stock turbo (EBPV removed) and intake. Last night, I updated/re-arranged the tunes that a previous owner had loaded to the Hydra. Pulled the PCM for the box code to enter into the HydraFlash software, and got it back in. Loaded the fuel sipper and whisper mode to the Hydra, drove around for a bit on the fuel sipper and the Daily Driver tunes, no issues whatsoever. Plugged the Hydra back in to my computer to remove the high-idle, extreme, and towing tunes, as I don't need them, and updating the Daily Driver tune, keeping the same hex code as the rest of the tunes I had loaded earlier and other tunes loaded already. This morning, I start it up and it seems to have a mild lope at idle and idling slightly faster than normal RPM, with the Daily Driver tune selected. Once I started driving, throttle was extremely sensitive and when I let off the accelerator, the engines starts to idle rough and the lope/chugging comes back much worse, and it has a sort of lurch to it, and lasts until I come to a complete stop. The transmission seems to shift at erratic points as well during acceleration. The issue happens any time there is any throttle give, regardless of speed. PO never had custom tunes loaded, so I am running the exact same tunes, except updated. Any advice or help would be greatly appreciated!

    **UPDATE**
    Tried re-loading tunes, and running in the "00" position, neither solved the issue.
    Last edited by WyoWildBill; 05-21-2017 at 04:39 PM. Reason: Added update

  2. #2
    JackandJanet's Avatar

    Join Date
    Mar 2015
    Location
    Under the Mogollon Rim in Aridzona
    Posts
    121

    Default Re: Rough idle when decelerating with new tunes on Hydra

    Hi WildBill - I deleted the other thread you posted on this problem in the Hardware Support Section. We've found that multiple threads on the same topic can lead to confusing responses that can waste your time.

    Somebody from PHP probably needs to help you and they MAY not see this post. I've noticed they don't really monitor the forum too often. So, I suggest you call them tomorrow. They're in Georgia, so they're on Eastern Daylight time there.

    - Jack
    2014 F150 Platinum 4x4 SCrew 3.5L Ecoboost


  3. #3

    Default Re: Rough idle when decelerating with new tunes on Hydra

    Thank you! I noticed it is throwing a code (DTC P0603), going to try clearing that and see if it fixes the issue. If not, Ill give PHP a call tomorrow morning and see what they can do.

    Also, my apologies for the duplicate thread! Been a few years since I've been on these boards.

  4. #4
    JackandJanet's Avatar

    Join Date
    Mar 2015
    Location
    Under the Mogollon Rim in Aridzona
    Posts
    121

    Default Re: Rough idle when decelerating with new tunes on Hydra

    No apologies needed! I'm just sorry I don't know more about diesels and the Hydra.

    Someone who DOES, is cleatus12r. He gets on the forum occasionally and I'm hoping he'll see your thread. He worked with PHP in Georgia for about a year before moving back up to the great Northwest.

    - Jack

  5. #5

    Default Re: Rough idle when decelerating with new tunes on Hydra

    There is no way that stock calibrations are going to work with injectors with larger nozzles as they will do exactly what you are saying they are doing.

    For the injectors to run correctly, tuning for them would have to be installed. As an aside, there is no need to ever "update" any tuning on the Hydra as the calibrations on the server are very rarely ever modified. You are going to have to get PHP to do some tuning for your injectors.

  6. #6
    JackandJanet's Avatar

    Join Date
    Mar 2015
    Location
    Under the Mogollon Rim in Aridzona
    Posts
    121

    Default Re: Rough idle when decelerating with new tunes on Hydra

    WildBill, follow cleatus' advice. Call PHP and have them create appropriate tunes for you.

    cleatus, thanks for seeing this and providing useful directions. Hope things are well with you.

    - Jack
    2014 F150 Platinum 4x4 SCrew 3.5L Ecoboost


  7. #7

    Default Re: Rough idle when decelerating with new tunes on Hydra

    Turns out I overwrote the old custom tunes meant for split shot injectors, have a new replacement tune on the way to get me back on the road. Thanks everyone!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •